Lifter Tick? - TCCoA Forums
 
LinkBack Thread Tools
post #1 of 5 (permalink) Old 08-04-2003, 06:33 PM Thread Starter
Seasoned PostWhore
 
Join Date: Sep 2002
Location: Erie, PA
Age: 35
Posts: 3,183
Send a message via AIM to KrAzyT
Lifter Tick?

in my 94 tbird I am having a slight lifter tick over 2000rpm's. Actually it gets pretty loud over 2500. The oil pressure guage was going up and down all the time for the last month I drove it. Now it doesnt move. What might it be? HELP!

1996 Thunderbird 4.6 -Sold-
259.4 hp and 285.3 tq on mustang dyno
Bunch of motorcycles
2004 F150
KrAzyT is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 08-06-2003, 06:39 AM Thread Starter
Seasoned PostWhore
 
Join Date: Sep 2002
Location: Erie, PA
Age: 35
Posts: 3,183
Send a message via AIM to KrAzyT
oh no did i stump everyone?

1996 Thunderbird 4.6 -Sold-
259.4 hp and 285.3 tq on mustang dyno
Bunch of motorcycles
2004 F150
KrAzyT is offline  
post #3 of 5 (permalink) Old 08-06-2003, 01:49 PM
Awaiting E-Mail Confirmation
 
sa t-bird's Avatar
 
Join Date: Sep 2002
Location: san antonio,tx
Age: 45
Posts: 76
Just a suggestion, but it could be the oil sender unit. I've changed mine three times now because of oil leaking aroung it. The gauge moves up and down and eventually will stop altogether. I just changed it again last night and I did notice ticking now it's gone and so is the puddle of oil under my car!!
sa t-bird is offline  
Sponsored Links
Advertisement
 
post #4 of 5 (permalink) Old 08-07-2003, 08:57 AM Thread Starter
Seasoned PostWhore
 
Join Date: Sep 2002
Location: Erie, PA
Age: 35
Posts: 3,183
Send a message via AIM to KrAzyT
I will change the sender unit soon & post everything that happens

1996 Thunderbird 4.6 -Sold-
259.4 hp and 285.3 tq on mustang dyno
Bunch of motorcycles
2004 F150
KrAzyT is offline  
post #5 of 5 (permalink) Old 08-07-2003, 10:01 AM
Seasoned PostWhore
 
Tx_Cat's Avatar
 
Join Date: Jul 2002
Location: El Paso, Tx
Age: 37
Posts: 3,391
Send a message via AIM to Tx_Cat Send a message via MSN to Tx_Cat Send a message via Yahoo to Tx_Cat
You know what, I had the same stupid problem.... And to my surprised, my freaking engine burned all of my oil, I had almost nothing. I thought it was the oil sender unit but it's ok..... So my car is burning to much oil and gas....


PhotobucketNitrous and boost go together like peanut butter and jellyPhotobucket


Nuttin make you feel more like a man in a Thunder Cougar Falcon Bird

Tx_Cat is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the TCCoA Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome