Fan Keeps running - TCCoA Forums
 
LinkBack Thread Tools
post #1 of 3 (permalink) Old 08-05-2003, 08:06 PM Thread Starter
4th Gear Poster
 
Join Date: Jul 2002
Location: Chicago
Posts: 236
Fan Keeps running

Fan runs for a long long time now since i replaced my old 95 4.6 with a 99 grand marquis engine. When i had the older engine the temp gauge ran between the blue notch and the N in norm, now its between the O and M in norm. After the car starts up it just run none stop.. I have the original T-stat from the Grand Marquis could that be the problem or something else??

99 NPI 4.6
SC Springs/Sway Bars
Trac Loc
J-Chip/L-Maf sensor
2.5 DynoMax exhaust with Hi-Flow Cats.
silvershot is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 08-05-2003, 10:21 PM
6th Gear Poster
 
MadRussian's Avatar
 
Join Date: Sep 2002
Location: Chesterfield, MO
Age: 35
Posts: 632
Send a message via AIM to MadRussian Send a message via MSN to MadRussian Send a message via Yahoo to MadRussian
Aren't you supposed to use a 180* thermostat with a chip?

-andrey

96 LX 4.6L
13.215 @ 103.09
MadRussian is offline  
post #3 of 3 (permalink) Old 08-05-2003, 10:46 PM
4th Gear Poster
 
Join Date: Jun 2003
Location: Garfield, NJ
Age: 51
Posts: 200
Not necessarily.

98 4.6 SOHC, J-Modded, B & M 24K Tranny Cooler, Cold Air Intake, 76 MM MAF, RM Tube, March 1150 U/D Pullies, Poly Bushings, Air Bags, MK VIII Brakes and Wheels, Trak-Lok w/ 3.55's MK VIII Flex plate and Marauder T/C. Now that it can go, it'll be time for show.
thndrchiken is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the TCCoA Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome