Need Help with 95 Bird - TCCoA Forums
 
LinkBack Thread Tools
post #1 of 8 (permalink) Old 07-17-2002, 11:37 PM Thread Starter
3rd Gear Poster
 
Join Date: Jul 2002
Location: MA
Age: 35
Posts: 190
Send a message via AIM to reaper
Angry Need Help with 95 Bird

I need alot of help with my 1995 4.6. It has been acting up alot lately. First it started to throw codes about once a month when pushed hard saying my #2 bank is running lean. After reading the code book I come to find this is the right hand bank. I believe this is the passenger side bank. Anyways, that code now pops up weekly, and I can't get it to go away. I look at the car and everything looks fine, it performs fine, it just throws codes. I was told it could be the Fuel Pressure Regulator but I am not positive it is the problem and since I'm a poor college student going back to school in a month, I can't afford to buy and install parts that don't fix the problem. Is there any way to tell if that IS the problem? Also can an aftermarket adjustable regulator be used in place of the stock regulator with the same results? And how do I go about adjusting the pressure?
Now for the next problem. I have a problem in the transmission or around it. When under light throttle especially at highway speeds I feel a clunking in the footweels of the car by the transmission tunnel. It is obvious the vibrating/thumping is coming from the transmission area, but what could it be? I checked for loose heat shields on the Cats and that is not a problem. Could it be a transmission mount or somethin more serious like a torque converter or the transmission itself? Also, how difficult is it to replace a transmission mount if it is broken, and how do I find out if it is or not? Thanks for any help you can give me on this.
reaper is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 07-18-2002, 07:30 PM
krusher
Guest
 
Posts: n/a
Had the same problem

Alright, had a 1995 bird that threw system too lean on both banks. More often than not its a vacuum leak. Replace the $5 gasket in the intake manifold and it might fix the problem. Also check all your vacuum hoses to see if they are connected ot cracked or anything else... Other than that you should replace your fuel filter. Its under the passenger side door. A clogged filter can lower your pressure enough to register a code. I'd check the regulator last. Good luck.
post #3 of 8 (permalink) Old 07-19-2002, 09:51 AM
Veteran Poster
 
Join Date: Jul 2002
Location: Albuquerque, NM
Posts: 803
Clean the MAF, tech article. If that doesn't fix it I would look at O2 sensors also. High mile cars that have run poorly for a long time ruin them.

If you only have one bank consistently lean, you may just have dirty injectors.
Buy the top end injector cleaning solvents and double up on the mix. Valvoline or Techron are my favorites.

rm

Most fun I ever had was with the Texas TCCOA guys making power and drag racing.


Now I am using a 2001 BMW M3 Vert for fun.
RichardM is offline  
Sponsored Links
Advertisement
 
post #4 of 8 (permalink) Old 07-19-2002, 10:07 AM
6th Gear Poster
 
Peter M's Avatar
 
Join Date: Jul 2002
Location: San Diego, CA
Age: 48
Posts: 573
One of my first mods was the MN12 MAF mod- boring the MAF sampling tube(just say no!). My car would consistantly throw right side lean codes and few if any left side codes, until I went back to a stock MAF. I agree, clean the MAF and check for a possible vac. leak. I would lean(no pun intended ) toward the MAF as the culprit.

Peter

SOLD 1996 4.6l Thunderbird-(fast) PI intake, custom exhaust, Bullet-Resistant Tranny™, blah, blah, blah
2007 VW GTI-(faster) United Grey, 18" wheels, APR stage 1 chip, and... uh... that's it for now.
________________________
..this space for rent..
Peter M is offline  
post #5 of 8 (permalink) Old 07-20-2002, 02:02 PM
PostWhore
 
95LX's Avatar
 
Join Date: Jul 2002
Location: PA
Posts: 1,846
Peter...

Do you have a website? I just wanted to see a closeup pic of your car. Looks tempting in the little icon there. Thanks.


Jim
95LX is offline  
post #6 of 8 (permalink) Old 07-22-2002, 09:00 AM
6th Gear Poster
 
Peter M's Avatar
 
Join Date: Jul 2002
Location: San Diego, CA
Age: 48
Posts: 573
I have to confess. The icon is a Photoshop touchup. It's only silver. BUT- one day I would like to do that paintjob. (sorry-no website right now, but if you want I can email a larger version)

Peter

SOLD 1996 4.6l Thunderbird-(fast) PI intake, custom exhaust, Bullet-Resistant Tranny™, blah, blah, blah
2007 VW GTI-(faster) United Grey, 18" wheels, APR stage 1 chip, and... uh... that's it for now.
________________________
..this space for rent..
Peter M is offline  
post #7 of 8 (permalink) Old 07-22-2002, 03:55 PM
PostWhore
 
95LX's Avatar
 
Join Date: Jul 2002
Location: PA
Posts: 1,846
Hey if you could, I'd still like to see a larger version of that. It looks nice anyway.


Jim
95LX is offline  
post #8 of 8 (permalink) Old 07-22-2002, 04:46 PM
6th Gear Poster
 
Peter M's Avatar
 
Join Date: Jul 2002
Location: San Diego, CA
Age: 48
Posts: 573
Look in the Misc. section of the Forums. I'm posting a poll on it...

Peter

SOLD 1996 4.6l Thunderbird-(fast) PI intake, custom exhaust, Bullet-Resistant Tranny™, blah, blah, blah
2007 VW GTI-(faster) United Grey, 18" wheels, APR stage 1 chip, and... uh... that's it for now.
________________________
..this space for rent..
Peter M is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the TCCoA Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome