injector stuck open - TCCoA Forums
 
LinkBack Thread Tools
post #1 of 3 (permalink) Old 05-30-2004, 08:11 AM Thread Starter
Seasoned PostWhore

Super Moderator
 
Join Date: May 2003
Location: Tinton Falls, NJ
Age: 36
Posts: 7,430
Garage
Send a message via AIM to MadMikeyL
injector stuck open

Ok, I started my car this morning and it was running rough and smoke was pouring out of the exhaust. When I got out the exhaust smelled like gas, and it white smoke was coming out in pulses out of the tailpipes. I figured out that the number 2 injector is stuck opened. I pulled the connector off of the injector and the exhaust still smelled like gas, so I figured it's the injector itself and not the eec, but once I got the injector out, I tried to blow through it to make sure it was bad, but I couldn't. I don't think there could be another bad injector because I pulled all the plugs and they were all fine except for #2 which was covered in gasoline. Before I go buy an injector and find out it's the eec, or buy an eec and find out it's the injector, can anyone tell me what you think it is. Thanks.

Mike
MadMikeyL is online now  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 05-30-2004, 12:51 PM
Refrigerator Raider Hater
Moderator
 
GreenBird's Avatar
 
Join Date: Jul 2002
Location: Vermont
Age: 35
Posts: 11,719
There was a problem with 94 computers, they sometimes fail and hang injectors open. Although I think #7 is the one that usually fails, which is the 2nd from the back on the driver's side.

Anyway, If it's the injector, you should be able to swap it to the other bank, and the symptom will also switch banks. If it doesn't, it would be the EEC or wiring.

Don't fret over buying an EEC, you can find them for twenty or thirty bucks. www.car-part.com, or "racecougar" or "LX-Tasy" on these boards.




Matt "Looks Like Egon" Davis
96 Alpine Green V8
98 Audi A8 4.2Q in Racing Green Totalled
02 Audi A8L 4.2Q in Black

I buy my OEM Ford parts at 10% over dealer cost from Steve in White Bear Lake, MN.
You drive "like a man possessed"... by a woman!
GreenBird is offline  
post #3 of 3 (permalink) Old 05-30-2004, 01:39 PM Thread Starter
Seasoned PostWhore

Super Moderator
 
Join Date: May 2003
Location: Tinton Falls, NJ
Age: 36
Posts: 7,430
Garage
Send a message via AIM to MadMikeyL
well I switched the injector over to a different port on the same bank, and after running the car for a while I checked the plugs, and the problem was still in the same cylinder. The strange thing though is that I disconnected the injector plug, and the problem still exists. Wouldn't disconnecting the plug leave the injector always closed?
MadMikeyL is online now  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the TCCoA Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome