Broken vacum hose? - TCCoA Forums
 
LinkBack Thread Tools
post #1 of 1 (permalink) Old 05-13-2007, 07:55 PM Thread Starter
5th Gear Poster
 
Join Date: May 2003
Location: new york city
Posts: 414
Question Broken vacum hose?

Need help. I snapped the hose that runs from the valve cover on the driver's side to the big hose that connects from the throttle body to the air cleaner. Does anybody know the name of that part and if possible have the part number to it. The part number was faded so i couldn't get to read it. It is a 96 thunderbird lx 3.8 v6 standard coupe, no supercharger, everything is stock. Any help would greatly be appreciated.
tino is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the TCCoA Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome