This piece of crap is driving me nuts - TCCoA Forums
 
LinkBack Thread Tools
post #1 of 22 (permalink) Old 09-10-2007, 01:34 AM Thread Starter
Seasoned PostWhore
 
The_Ghost's Avatar
 
Join Date: Jun 2006
Location: Los Alamitos, CA
Age: 34
Posts: 2,055
This piece of crap is driving me nuts

I am trying to fix up this piece of crap 94 LX 3.8L. It is a piece of crap.

It runs hot, and the elec fan is not engaging, and it has killed TWO radiators inside of a week. I can't figure it out. Maybe I just got a bad radiator the 2nd time?? But it leaked from the same spot, which is weird, or maybe that's just where fluid will leave the rad support, I don't know.

Anyhow, yeah.

It still runs like crap, this thing.

It and its damned DIS ignition system. Seriously, the tach still acts ridiculous (Indicating 500-1700rpm, after that it drops to zero, and will sit there until the rpms drop real low again), and the car stumbles more than a eight month old trying to walk for the first time. It's freaking ridiculous. and it gets crappy fuel economy.
and it yields almost no vacuum... I had a hard time feeding this piece of crap Seafoam.

This car is really beginning to irritate me. Not even my SC was this big of a pain in the ass.

So yeah, I like, really need help with this piece of junk.

Thanks, Ghost

/frustrated rant

96 Laser Red 4.6L - Custom
Custom Nascar-Inspired Bodykit - 55* Rear Spoiler - J-modded Trans - 80mm MAF - One-Off Diablosport Chipmaster Revolution Chip/Tune W/Toggle - ScanGaugeII Diagnostics & Data Readout - PBR Brakes - Drilled/Slotted Rotors - SC Wheels & Springs - Falken Tires - KYB GR-1 Shocks/Struts - FSTB - RSTB - RTLB - LECB - 60/40 Split Rear - SC Seats - SC Vac/Boost Gauge
The_Ghost is offline  
Sponsored Links
Advertisement
 
post #2 of 22 (permalink) Old 09-10-2007, 04:11 AM
PostWhore
The AFDB is on a lil tight.
 
Splattered's Avatar
 
Join Date: Mar 2007
Location: is hot
Posts: 3,868
New everything maybe could fix it, I wish I could help you but it sounds like this car is in need of organ transplants.

Spinning pies like wheels.

DD driving my 20 year old project

Now with new ball joints...again
Splattered is offline  
post #3 of 22 (permalink) Old 09-10-2007, 06:23 PM
Newbie
Moderator
 
master486's Avatar
 
Join Date: Jun 2006
Location: San Diego
Age: 32
Posts: 5,650
Have you tried changing the coolant temp sensor yet? And the crank sensor as well? Both are cheap.

--Chris

DirtyDog Torque Converter For Sale!!
Huge Parts Sale!!

1996 Thunderbird LX
Awaiting some tender deconstruction...
master486 is offline  
Sponsored Links
Advertisement
 
post #4 of 22 (permalink) Old 09-10-2007, 09:09 PM
Seasoned PostWhore
 
jco1385's Avatar
 
Join Date: May 2007
Location: Mobile, AL
Posts: 3,746
Garage
**cough cough** car crusher... **cough cough**

1994 Thunderbird - 2000 4.2L M5R2 now has 55k

1995 Thunderbird - 2002 Alum 4.6L SVO - Awaiting transplant... (Parts donor)

1996 Cougar - 2004 3.9L 4R70W - Part-out soon
jco1385 is offline  
post #5 of 22 (permalink) Old 09-10-2007, 09:24 PM
It is nice
 
Join Date: Aug 2004
Location: Arizona
Age: 37
Posts: 885
It runs hot bc the fan is not engaging so that is probably why the radiators are bursting. You should really have the fan looked at and see what's wrong. Wouldn't hurt to changed the antifreeze and thermostat for starters. sounds like you have a vacuum leak somewhere check all ur lines, brake booster, iac, etc. or some sort of other electrical malfunction maybe.

1997 Ford Thunderbird LX 4.6L (WT): Removed Air Silencer. PBR Brake Upgrade. J-MOD. Silverstar Headlights. Vogtland Springs 1.6". Front Sport Shocks/ Back KYB's. PI Cams. Xcal2 by Lonnie.
1991 Mercury Cougar LS 3.8L: SOLD
91CougarLS is offline  
post #6 of 22 (permalink) Old 09-10-2007, 10:09 PM Thread Starter
Seasoned PostWhore
 
The_Ghost's Avatar
 
Join Date: Jun 2006
Location: Los Alamitos, CA
Age: 34
Posts: 2,055
they keep leaking right out of the dead center of the effing rad. i also think the junk rad i bought might've been damaged.

-ghost

96 Laser Red 4.6L - Custom
Custom Nascar-Inspired Bodykit - 55* Rear Spoiler - J-modded Trans - 80mm MAF - One-Off Diablosport Chipmaster Revolution Chip/Tune W/Toggle - ScanGaugeII Diagnostics & Data Readout - PBR Brakes - Drilled/Slotted Rotors - SC Wheels & Springs - Falken Tires - KYB GR-1 Shocks/Struts - FSTB - RSTB - RTLB - LECB - 60/40 Split Rear - SC Seats - SC Vac/Boost Gauge
The_Ghost is offline  
post #7 of 22 (permalink) Old 09-10-2007, 10:38 PM
PostWhore
 
thewishkah's Avatar
 
Join Date: Sep 2006
Location: Brooklyn NY
Age: 35
Posts: 1,731
Send a message via AIM to thewishkah
get another rad, a new temp sensor(4-5$) at autozone, new 180* t-stat-12$, flush the system, and back flush the heater core. run a jumper wire from the fan to the + on the batteryand to a ground, if it doesn't budge get a new fan motor (100$ from autozone) or get a used one from a yard just make sure it works. If it does work your ccrm has an issue and needs replacing(im pretty sure thats what its called).

As for the vacuum issue, use some carb spray and spray it around all vacuum hoses when the idle goes up you found the culprit. dont give up on it yet man it isn't hard to get great mileage out of the 3.8, i avg 30mpg on the highway with a/c. just keep it going you'll get there.
thewishkah is offline  
post #8 of 22 (permalink) Old 09-10-2007, 11:38 PM Thread Starter
Seasoned PostWhore
 
The_Ghost's Avatar
 
Join Date: Jun 2006
Location: Los Alamitos, CA
Age: 34
Posts: 2,055
yeah the thing is I have a limited amount of time to figure this damn thing out!

For what it's worth, the brakes are also really awful. Maybe a huge vac leak at the brake booster?

96 Laser Red 4.6L - Custom
Custom Nascar-Inspired Bodykit - 55* Rear Spoiler - J-modded Trans - 80mm MAF - One-Off Diablosport Chipmaster Revolution Chip/Tune W/Toggle - ScanGaugeII Diagnostics & Data Readout - PBR Brakes - Drilled/Slotted Rotors - SC Wheels & Springs - Falken Tires - KYB GR-1 Shocks/Struts - FSTB - RSTB - RTLB - LECB - 60/40 Split Rear - SC Seats - SC Vac/Boost Gauge
The_Ghost is offline  
post #9 of 22 (permalink) Old 09-10-2007, 11:55 PM
Pedal Faster
 
Josh_Keady's Avatar
 
Join Date: Jul 2002
Location: No. Oregon
Age: 35
Posts: 2,658
Send a message via AIM to Josh_Keady
Bingo. Cap off the brake booster vac line (make sure it's actually connected at the motor), drive it around the block and see what happens.

Josh Keady

1994 Super Coupe ('93 5.0L swap), 1990 Tbird 3.8L, 1982 Honda CB900F, 1972 F-100 SportCustom 4x4, 1970 Chevy Custom Camper / 20
Josh_Keady is offline  
post #10 of 22 (permalink) Old 09-13-2007, 02:30 PM
PostWhore
 
Join Date: Nov 2002
Location: SouthEastern PA
Posts: 1,112
I don't know what you have replaced on the car, but if the car runs fine while the tach dies, the problem is probably with the tach and not with the cam sensor or DIS. If the car stumbles at the same time as the tach, you likely have a shorted wire or a bad component in that system. It would help to check the vacuum out first, though.

-------------------

Steve

Owner, 1990 Thunderbird SC, white w/ gray cloth
S_Mazza is offline  
post #11 of 22 (permalink) Old 09-15-2007, 02:52 AM Thread Starter
Seasoned PostWhore
 
The_Ghost's Avatar
 
Join Date: Jun 2006
Location: Los Alamitos, CA
Age: 34
Posts: 2,055
the car stumbles totally out of synch with the tach. the tach is crazy on its own

96 Laser Red 4.6L - Custom
Custom Nascar-Inspired Bodykit - 55* Rear Spoiler - J-modded Trans - 80mm MAF - One-Off Diablosport Chipmaster Revolution Chip/Tune W/Toggle - ScanGaugeII Diagnostics & Data Readout - PBR Brakes - Drilled/Slotted Rotors - SC Wheels & Springs - Falken Tires - KYB GR-1 Shocks/Struts - FSTB - RSTB - RTLB - LECB - 60/40 Split Rear - SC Seats - SC Vac/Boost Gauge
The_Ghost is offline  
post #12 of 22 (permalink) Old 09-17-2007, 04:45 PM
PostWhore
 
Join Date: Nov 2002
Location: SouthEastern PA
Posts: 1,112
Well, ok. Sounds like it could be vacuum. I dunno. It could be a mechanical issue too, I suppose. If it runs ok part of the time, that probably rules out something mechanical being utterly busted. I wonder if you have problems with fuel or fuel filter?

-------------------

Steve

Owner, 1990 Thunderbird SC, white w/ gray cloth
S_Mazza is offline  
post #13 of 22 (permalink) Old 09-18-2007, 01:31 AM Thread Starter
Seasoned PostWhore
 
The_Ghost's Avatar
 
Join Date: Jun 2006
Location: Los Alamitos, CA
Age: 34
Posts: 2,055
a fuel filter isnt out of the question.

I wonder if this **** has the stock one?

But then that wouldnt explain the tach. Perhaps I should put a new one in it and see what happens??

96 Laser Red 4.6L - Custom
Custom Nascar-Inspired Bodykit - 55* Rear Spoiler - J-modded Trans - 80mm MAF - One-Off Diablosport Chipmaster Revolution Chip/Tune W/Toggle - ScanGaugeII Diagnostics & Data Readout - PBR Brakes - Drilled/Slotted Rotors - SC Wheels & Springs - Falken Tires - KYB GR-1 Shocks/Struts - FSTB - RSTB - RTLB - LECB - 60/40 Split Rear - SC Seats - SC Vac/Boost Gauge
The_Ghost is offline  
post #14 of 22 (permalink) Old 09-18-2007, 01:32 AM Thread Starter
Seasoned PostWhore
 
The_Ghost's Avatar
 
Join Date: Jun 2006
Location: Los Alamitos, CA
Age: 34
Posts: 2,055
Damnit, were this piece of crap OBDII I could at least use the computer to see whether or not the computer is seeing screwball tach signals.

96 Laser Red 4.6L - Custom
Custom Nascar-Inspired Bodykit - 55* Rear Spoiler - J-modded Trans - 80mm MAF - One-Off Diablosport Chipmaster Revolution Chip/Tune W/Toggle - ScanGaugeII Diagnostics & Data Readout - PBR Brakes - Drilled/Slotted Rotors - SC Wheels & Springs - Falken Tires - KYB GR-1 Shocks/Struts - FSTB - RSTB - RTLB - LECB - 60/40 Split Rear - SC Seats - SC Vac/Boost Gauge
The_Ghost is offline  
post #15 of 22 (permalink) Old 09-18-2007, 03:39 PM
PostWhore
 
Join Date: Nov 2002
Location: SouthEastern PA
Posts: 1,112
Do you have the VMM? If so, there may be a way to check the tach signal through that. You can do so on the older VMMs, anyway. (I know it sounds silly, but it does work.)

-------------------

Steve

Owner, 1990 Thunderbird SC, white w/ gray cloth
S_Mazza is offline  
post #16 of 22 (permalink) Old 09-18-2007, 07:06 PM Thread Starter
Seasoned PostWhore
 
The_Ghost's Avatar
 
Join Date: Jun 2006
Location: Los Alamitos, CA
Age: 34
Posts: 2,055
I *have* a VMM for a 89-93 but this is a 94 NA 3.8L. It is truly a worthless piece of ****

There's a whole lot of neat stuff you can do through that little piece of crap VMM that's really well hidden

96 Laser Red 4.6L - Custom
Custom Nascar-Inspired Bodykit - 55* Rear Spoiler - J-modded Trans - 80mm MAF - One-Off Diablosport Chipmaster Revolution Chip/Tune W/Toggle - ScanGaugeII Diagnostics & Data Readout - PBR Brakes - Drilled/Slotted Rotors - SC Wheels & Springs - Falken Tires - KYB GR-1 Shocks/Struts - FSTB - RSTB - RTLB - LECB - 60/40 Split Rear - SC Seats - SC Vac/Boost Gauge
The_Ghost is offline  
post #17 of 22 (permalink) Old 09-18-2007, 07:37 PM
Seasoned PostWhore
 
95xbird's Avatar
 
Join Date: Apr 2006
Location: Buffalo, NY
Age: 36
Posts: 4,407
Send a message via AIM to 95xbird Send a message via MSN to 95xbird
I just skimmed the thread but if your fan isn't working at all than I would start with the fan Relay behind the headlamp.

04 PI swap,SVO Supercharger 8-9 psi,Alcohol injection,39lbs Cobra injectors,XCal2-Walbro 255 LPH fuel pump,4.10 T-Lok,2003 4R70W built to withstand by RobertP,450hp JMOD,3800 circleD stall,trucool 4739 Trans Cooler,Dynotech 3.5 Driveshaft,70mm T/B,SCP Cold Air Intake,90mm LMAF,JBA headers,Magnaflow Midmount,No cats with 3inch piping,Vogtland 1.6inch drop,Cobra R's and xenon body kit.

Its slow, Really.
LS1 KILLER
1995 svo Tbird. R.I.P.
Parts FOR SALE http://forums.tccoa.com/showthread.php?t=132585
96 Pearl white bird. Awaiting transplants from the 95
95xbird is offline  
post #18 of 22 (permalink) Old 09-19-2007, 12:45 AM Thread Starter
Seasoned PostWhore
 
The_Ghost's Avatar
 
Join Date: Jun 2006
Location: Los Alamitos, CA
Age: 34
Posts: 2,055
beyond the fan not coming on the tachometer acts ridiculous

96 Laser Red 4.6L - Custom
Custom Nascar-Inspired Bodykit - 55* Rear Spoiler - J-modded Trans - 80mm MAF - One-Off Diablosport Chipmaster Revolution Chip/Tune W/Toggle - ScanGaugeII Diagnostics & Data Readout - PBR Brakes - Drilled/Slotted Rotors - SC Wheels & Springs - Falken Tires - KYB GR-1 Shocks/Struts - FSTB - RSTB - RTLB - LECB - 60/40 Split Rear - SC Seats - SC Vac/Boost Gauge
The_Ghost is offline  
post #19 of 22 (permalink) Old 09-19-2007, 12:51 AM
Pedal Faster
 
Josh_Keady's Avatar
 
Join Date: Jul 2002
Location: No. Oregon
Age: 35
Posts: 2,658
Send a message via AIM to Josh_Keady
I would almost bet the ECM has gone wonky. But before that, have you verified that the booster is not leaking vacuum?

Josh Keady

1994 Super Coupe ('93 5.0L swap), 1990 Tbird 3.8L, 1982 Honda CB900F, 1972 F-100 SportCustom 4x4, 1970 Chevy Custom Camper / 20
Josh_Keady is offline  
post #20 of 22 (permalink) Old 09-19-2007, 02:02 AM Thread Starter
Seasoned PostWhore
 
The_Ghost's Avatar
 
Join Date: Jun 2006
Location: Los Alamitos, CA
Age: 34
Posts: 2,055
Not really. I've sprayed water at stuff and idle stays ok. How would you recommend I check?

-ghost

96 Laser Red 4.6L - Custom
Custom Nascar-Inspired Bodykit - 55* Rear Spoiler - J-modded Trans - 80mm MAF - One-Off Diablosport Chipmaster Revolution Chip/Tune W/Toggle - ScanGaugeII Diagnostics & Data Readout - PBR Brakes - Drilled/Slotted Rotors - SC Wheels & Springs - Falken Tires - KYB GR-1 Shocks/Struts - FSTB - RSTB - RTLB - LECB - 60/40 Split Rear - SC Seats - SC Vac/Boost Gauge
The_Ghost is offline  
post #21 of 22 (permalink) Old 09-19-2007, 02:16 AM
Pedal Faster
 
Josh_Keady's Avatar
 
Join Date: Jul 2002
Location: No. Oregon
Age: 35
Posts: 2,658
Send a message via AIM to Josh_Keady
Pull the line off of the booster and plug it.

Josh Keady

1994 Super Coupe ('93 5.0L swap), 1990 Tbird 3.8L, 1982 Honda CB900F, 1972 F-100 SportCustom 4x4, 1970 Chevy Custom Camper / 20
Josh_Keady is offline  
post #22 of 22 (permalink) Old 09-20-2007, 10:37 PM Thread Starter
Seasoned PostWhore
 
The_Ghost's Avatar
 
Join Date: Jun 2006
Location: Los Alamitos, CA
Age: 34
Posts: 2,055
Success! I sold that piece of crap!

-Ghost

96 Laser Red 4.6L - Custom
Custom Nascar-Inspired Bodykit - 55* Rear Spoiler - J-modded Trans - 80mm MAF - One-Off Diablosport Chipmaster Revolution Chip/Tune W/Toggle - ScanGaugeII Diagnostics & Data Readout - PBR Brakes - Drilled/Slotted Rotors - SC Wheels & Springs - Falken Tires - KYB GR-1 Shocks/Struts - FSTB - RSTB - RTLB - LECB - 60/40 Split Rear - SC Seats - SC Vac/Boost Gauge
The_Ghost is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the TCCoA Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome