One strange bird. - TCCoA Forums
 
LinkBack Thread Tools
post #1 of 5 (permalink) Old 03-02-2008, 10:04 PM Thread Starter
 
Join Date: Feb 2008
Posts: 2
One strange bird.

Hey everyone, Im new here and been lurking for a while and I finally have a good post. My 91 t-bird was given to me by my neighbor after she has put thousands in new heads, transmission, All Front suspension and new tires. I saved her from a trip to the junk yard when the alternator went and killed the battery on her trip to work. Thats how she got the name freebird, anyway, to try to make a long story short. My low oil presure light flickers from time to when im stoped at a light and im in gear but im not woried I found several sensor/wire problems with that. My concern is that in the mornings I have a death rattle. The oil presure light is out when it does this, it only lasts a second at the most. I run a motorcraft filter and motorcraft 10w30 oil with one qt of lucas oil treatment, any ideas? also... Behind my drivers seat the floor is always wet, there is a sunroof in the car but I can spray it with water for thirty min and it wont get wet but if it rains the floor is soaked. Any ideas with either one of these problems
91freebird is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 03-02-2008, 10:13 PM
Seasoned PostWhore
 
rbrown's Avatar
 
Join Date: Aug 2002
Location: Houston Clear Lake
Posts: 7,061
The sunroof is the drain tube. It's located behind the speakers in the back seat panels. Don't be surprised to see lots of rust in there.

Sounds like you have a low volume of oil. Have you checked it.
Outside of this obvious one, some have used an antidrainback oil filter. And I would suspect lifter noise. Could be signs of a rebuild soon.

But I will add. My V8 will run low on oil, all sorts of noise. Top it off and alls well. Then one morning I get the noises. Oil is fine. Sound goes away. I am waiting for it to die but it just doesn't. Runs great as a matter of fact.

Last edited by rbrown; 03-02-2008 at 10:21 PM.
rbrown is offline  
post #3 of 5 (permalink) Old 03-02-2008, 10:15 PM
PostWhore
 
MadGoat's Avatar
 
Join Date: Apr 2004
Location: Tucson, AZ
Age: 34
Posts: 1,072
Send a message via AIM to MadGoat Send a message via MSN to MadGoat
Death rattle, How cold is it outside?

Lucas additive and 10w-30 make for a pretty thick mixture. that cold oil is taking awhile to loosen up and make it up to the top end of the engine. use a lighter oil 'till it gets warmer out. Sensor is more than likley a loose connection or temperamental oil pressure sensor. The interior water is more than likely from the door weatherstripping on the passanger side. Had to re-glue my weather stripping up this winter as well, looked fine... but it was for sure leaking. grab some $4 goop and make sure you clean both the metal and rubber before you apply the glue, it doesnt like to stick to years of crap.

~MG~

MadGoat's Birds
94 Thunderbird LX 4.6L PI
03 Aluminum PI Engine, J-Mod, Aluminum one piece drive shaft, 3.27's, 2.5" to single 3" custom MagnaFlow exhaust, 07 17x8 Bullit Wheels
97 Thunderbird LX 4.6L V8
RIP
MadGoat is offline  
Sponsored Links
Advertisement
 
post #4 of 5 (permalink) Old 03-02-2008, 10:17 PM
PostWhore
 
MadGoat's Avatar
 
Join Date: Apr 2004
Location: Tucson, AZ
Age: 34
Posts: 1,072
Send a message via AIM to MadGoat Send a message via MSN to MadGoat
Quote:
Originally Posted by rbrown View Post
The sunroof is the drain tube. It's located behind the speakers in hte back seat panels. Don't be surprised to see lots of rust in there.

Sounds like you have a low volume of oil. Have you checked it.
Outside of this obvious one, some have used an antidrainback oil filter. And I would suspect lifter noise. Could be signs of a rebuild soon.

But I will add. My V8 will run low on oil, all sorts of noise. Top it off and alls well. Then one morning I get the noises. Oil is fine. Sound goes away. I am waiting for it to die but it just doesn't. Runs great as a matter of fact.

good point, didnt think of the rain gutter ;-)

~MG~

MadGoat's Birds
94 Thunderbird LX 4.6L PI
03 Aluminum PI Engine, J-Mod, Aluminum one piece drive shaft, 3.27's, 2.5" to single 3" custom MagnaFlow exhaust, 07 17x8 Bullit Wheels
97 Thunderbird LX 4.6L V8
RIP
MadGoat is offline  
post #5 of 5 (permalink) Old 03-02-2008, 10:40 PM Thread Starter
 
Join Date: Feb 2008
Posts: 2
Hey thanks for the quick response. Well it dosent seem to matter on outside temp it can be between 19 and 91 outside and its the same noise. as far as the drain tube i can watch water run out of tube infront of the rear wheel but if thats where the tube runs i will check that close in the morning. This thing had a really expensive aftermarket sunroof installed by the dealer when new and im going to have to do the headliner, anyone know if a hollandia sunroof would use the same drain tubes as a factory job?
91freebird is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the TCCoA Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome