Need Throttle / Accelerator Cable - TCCoA Forums
 
LinkBack Thread Tools
post #1 of 5 (permalink) Old 09-24-2011, 06:25 PM Thread Starter
Newbie
 
Thunderbird777's Avatar
 
Join Date: Dec 2006
Location: Southern California
Age: 37
Posts: 5
Exclamation Need Throttle / Accelerator Cable

Hello All !

I have a 1996 T-bird with the 3.8 V6. Had a problem on Wednesday with my accelerator sticking (driving an out of control Thunderbird is NOT fun) but alas I'm ok and so is the car....

Anyways after popping the hood and checking the throttle cable it appears to be jamming or sticking and needs to be replaced before it's safe to drive again. Apparently Ford has discontinued this part and so far I have had no luck looking for an after-market replacement. Any ideas here ????

Last course of action would be to pull it from a Thunderbird at a wrecking yard, but I'd rather get a new part just to be on the safe side.
Thunderbird777 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 09-24-2011, 07:39 PM
PostWhore
 
cobra R Thunderbird's Avatar
 
Join Date: Dec 2009
Location: Thomasville GA
Age: 34
Posts: 1,488
Test one at a junk yard and if its good grab it. Disconnect it from the TB and see how easily & smooth it glides.. That's what ide do...

1995 Tbird ~ 02 explorer SVO 4.6 Sold
1986 built/restored notch body mustang ~ appears as a 91+ built 5.0 gt40p, Ud pullies, ss headers, msd everything, arp head bolts, 1.7 crane roller rockers, B303 cam, Holley carb, high rise intake,5 speed, steeda everything. Sold
2001 GT BULLITT #00762 stock
2000 GT ~ 310 rwhp on mustang dyno. 08 2v, super low miles, comp 262 cams, bbk ud pullies, ported bullitt intake/accufab TB, 24# injectors, dyno tuned, 3inch pypes catless x pipe system, cobra brakes, coated cross & drilled rotors, Cobra r hood, 99-01 cobra front bumper, & 01-04 side scoops, dropped
2003 z71 avalanche fully loaded
cobra R Thunderbird is offline  
post #3 of 5 (permalink) Old 09-25-2011, 05:02 AM
MA Chapter Director

Administrator
 
Rodeo Joe's Avatar
 
Join Date: Jul 2002
Location: Franklin, MA
Age: 62
Posts: 7,959
Garage
Agreed. Double check the TB to make sure the linkage is moving freely.

Joe

It's not a 97 Sport, it just looks like one!

Mass. TCCoAers, Send me your info!

I buy all my Ford parts from 93 lx.

Member of the TCCoA Damage Control Team.

R.I.P. Johnny Langton 1975 - 2011
Rodeo Joe is offline  
Sponsored Links
Advertisement
 
post #4 of 5 (permalink) Old 10-01-2011, 04:36 PM
Newbie
 
BlueBirdJono's Avatar
 
Join Date: May 2010
Location: Denver, CO
Age: 35
Posts: 4
Throttle Cable alternative

My cable snapped about 9 months ago and I couldn't find a good source either. I ended up adapting a '98 mustang assembly (cable, housing, and TB bracket) because the parts were still available from Ford. Just an option...
BlueBirdJono is offline  
post #5 of 5 (permalink) Old 10-14-2011, 12:53 AM Thread Starter
Newbie
 
Thunderbird777's Avatar
 
Join Date: Dec 2006
Location: Southern California
Age: 37
Posts: 5
Thanks all, I found a good one at a wrecking yard, I just think it's crazy that NOBODY makes this cable anymore.
Thunderbird777 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the TCCoA Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome