temperature reaching critical captain! - TCCoA Forums
 
LinkBack Thread Tools
post #1 of 6 (permalink) Old 01-10-2004, 09:43 PM Thread Starter
 
Join Date: Aug 2002
Posts: 861
temperature reaching critical captain!

hey! my car is having bouts of fever. the temperature gauge started flucuating earlier today, so it'll go up, then down, then up then down again, then hold pretty steady in the middle. now i don't think it's headgaskets because 1) already been replaced once, 2) no coolant disaperaing, 3) over flow tank full of nice green coolant and no oil, and also because the engine isn't even hot. nor is the upper radiator hose, just midly warm. and the heater works quite well. i replaced t-stat a week or so ago w/ a 180* one, and i didn't get a good seal on the t-stat housing so it's leaking a bit there. also, when i checked to see if engine was hot or not, there were bubble coming up the overflow tank?
XR7kid is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 01-11-2004, 02:54 AM
Moderator
Iowa Chapter Director
Uber Luber
TCCoAAC Member
Moderator
 
Thomas's Avatar
 
Join Date: Jul 2002
Location: Ames, Iowa
Age: 35
Posts: 8,978
you could have air in the system.

1988 Notch Mustang: - 438W, direct port n2o, t56
2003 SVT Focus: - SCT X3 tuner
Thomas is offline  
post #3 of 6 (permalink) Old 01-11-2004, 01:54 PM Thread Starter
 
Join Date: Aug 2002
Posts: 861
any special way to get the air out?
XR7kid is offline  
Sponsored Links
Advertisement
 
post #4 of 6 (permalink) Old 01-11-2004, 03:54 PM
cougarman is offline  
post #5 of 6 (permalink) Old 01-11-2004, 04:21 PM
PostWhore
 
PJ-4.2L's Avatar
 
Join Date: Jul 2002
Location: Westlake Village, CA
Age: 39
Posts: 1,013
Send a message via AIM to PJ-4.2L
Quote:
Originally posted by XR7kid
... i didn't get a good seal on the t-stat housing so it's leaking a bit there...
There's your problem.

PJ

PJ- 4.2L -
" 'DIY' was not meant for women."
PJ-4.2L is offline  
post #6 of 6 (permalink) Old 01-11-2004, 08:24 PM
PCD
Confirmed V6 Nut
 
Join Date: Aug 2002
Location: Dubuque, Iowa
Age: 63
Posts: 2,261
XR7Kid,

I hope you didn't bend the T-stat housing. Easy enough to do after you get frustrated putting in that damn t-stat.

The Parts Bin Special is DEAD! It is being parted out.
PCD is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the TCCoA Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome