Thermostat housing again - TCCoA Forums
 
LinkBack Thread Tools
post #1 of 5 (permalink) Old 01-13-2004, 02:04 PM Thread Starter
 
Join Date: Dec 2003
Posts: 73
Thermostat housing again

I have replaced the thermostat housing gasket 4 times and the damn thing still leaks! Its not a bad leak but still it just pisses me off. I called around to see if i could just buy another thermostat housing but, I have the unique gonzo nose looking one that only the dealership carrys. And im not paying $93 for a new one. This last time I replaced it when I was cleaning out my lower intake manifold. I did it buy the book. I took a fine bristled wire wheel and polished all the gasket surfaces. I applied sealant to both sides gaket. Perfectly aligned the gasket with the housing and torqed both bolts. WTF? Am I not suppose to use sealant?
sonicman1634 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 01-13-2004, 03:05 PM
 
Join Date: Jan 2003
Posts: 724
Might be warped. Take it off an dlay it on something flat. You'll know right away if it's warped or not. If it is, and it's stamped steel like mine was, just take a hammer and punch and pound it back into shape. Just take care not to pound through it.
93SC is offline  
post #3 of 5 (permalink) Old 01-13-2004, 03:31 PM
Motorboatin' SOB
Headlight Cleaning Guru
 
big mike's Avatar
 
Join Date: Jul 2002
Location: H-town, TX
Posts: 6,910
Send a message via AIM to big mike
yes you need sealant. you dont need a new housing, just hit up the junkyards for a used one, or keep your eyes peeled for guys here parting out their cars.

2014 GT
1990 300ZX TT
big mike is offline  
Sponsored Links
Advertisement
 
post #4 of 5 (permalink) Old 01-13-2004, 03:45 PM
Johnny Bling Bling
 
93 lx's Avatar
 
Join Date: Jul 2002
Location: Lunenburg, MA
Age: 41
Posts: 3,811
Send a message via AIM to 93 lx
Thumbs up

if you want, i can sell you a new one for $48 plus shipping. lmk.

-jon

2003 Ford Expedition: 5.4L, harley supercharger, 2.93 upper pulley, 4lb lower pulley, c&l plenum, jlp cai, LFP SBTB, FTSP, Magnaflow 3" catback, Eclipse AVN-5510, white face gauges, cobalt c2 boost gauge, ddm hid's, 379 rwhp, 465 rwtq sold 11/3/12

2009 Ford Flex Limited AWD
93 lx is offline  
post #5 of 5 (permalink) Old 01-13-2004, 08:59 PM Thread Starter
 
Join Date: Dec 2003
Posts: 73
I think I might be complaing about nothing. I looked at it today and notice any coolant coming out of it. Maybe i just didnt give the sealant enough time to sit.
sonicman1634 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the TCCoA Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome