Bad starters - TCCoA Forums
 
LinkBack Thread Tools
post #1 of 2 (permalink) Old 03-05-2005, 06:14 PM Thread Starter
3rd Gear Poster
 
Join Date: Feb 2005
Location: Ottawa,Ontario,Canada
Age: 73
Posts: 160
Question Bad starters

After 9 years my starter went on my 1994 3.8 in August 2003.I purchased a NAPA rebuilt starter at that time . Since then the rebuilt starter has failed twice.Funny how they never fail at your home so now after $200.00 spent on towing I,m back running again and what I was wondering if other people have had this trouble and if so is their a better source for starters.The failing in both cases was the little solenoid which Ford apparently does not service.The latest replacement seems to have a reworked solenoid and hopefully this is the cure regards Jim
park7163 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 03-05-2005, 06:42 PM
Moderator
Iowa Chapter Director
Uber Luber
TCCoAAC Member
Moderator
 
Thomas's Avatar
 
Join Date: Jul 2002
Location: Ames, Iowa
Age: 35
Posts: 8,978
my remanned starter came with the re-designed solenoid and it's been 2 1/2 years now since I put it in.
-Thomas

1988 Notch Mustang: - 438W, direct port n2o, t56
2003 SVT Focus: - SCT X3 tuner
Thomas is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the TCCoA Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome