slight coolent leak - TCCoA Forums
 
LinkBack Thread Tools
post #1 of 5 (permalink) Old 04-12-2005, 09:28 PM Thread Starter
 
Join Date: Jan 2005
Posts: 755
slight coolent leak

I think I might have a slight coolent leak. My overflow tank keeps slowly emptying. I just filled it with coolent like last month or two. Is that normal? My friends taurus loses it faster though, but I wanted to check
NiteFire is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 04-12-2005, 09:37 PM
 
Join Date: Jan 2003
Posts: 253
I had a similiar issue awhile ago, actually it turned out to be two things. 1) A crack in the plastic housing on the side of the radiator, took forever to find that one. 2) The radiator cap was old and wasn't sealing properly anymore. There could be other problems, but if your only symptom is slow coolant lose, start small. If you have other symptoms as well, post them up and maybe someone else chime in.
rocket_dj is offline  
post #3 of 5 (permalink) Old 04-12-2005, 09:40 PM
 
Join Date: Dec 2002
Posts: 162
Could be losing some coolant with a loose overflow tube. Just noticed that on mine a few days ago. Slammed a small clamp on it just for extra precaution.
ChitownLX is offline  
Sponsored Links
Advertisement
 
post #4 of 5 (permalink) Old 04-12-2005, 11:20 PM
The Parts Guy
 
racecougar's Avatar
 
Join Date: Jul 2002
Location: Imperial, Missouri (near St. L
Age: 36
Posts: 7,265
I'd recommend pulling up the carpet on the passenger side front floorboard and checking for coolant there. Everytime I've had a slow leak in any of my MN12's, it was the heater core, and you wouldn't notice the coolant on the passenger side floor unless you pulled up the carpet to have a look.

-Rod

Rod @ AzzKicker Cars
[email protected]
90 XR7-The Meth Addict-KB SC'd 5.0L DOHC Stroker
2004 Mustang GT-The Driver-Intake/Exhaust/3.73's
1995 F150 4x4-The Mud Toy-5.0L/4R70W/33's/Warn 8274 Winch
94 LX w/Splitport 3.8L from 2000 Mustang - SOLD
2 - 90 35th Anny Ed SC's
And a TON of parts cars!
racecougar is offline  
post #5 of 5 (permalink) Old 04-13-2005, 10:46 AM
 
Join Date: Mar 2003
Posts: 278
Quote:
Originally Posted by rocket_dj
...A crack in the plastic housing on the side of the radiator, took forever to find that one...
I have the small coolant leake too and I've checked just about everything, but I never heard about that, I'll have to check it out.
232slow4me is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the TCCoA Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome