tbird probs :( - TCCoA Forums
 
LinkBack Thread Tools
post #1 of 15 (permalink) Old 08-26-2005, 05:29 PM Thread Starter
 
Join Date: Jun 2005
Posts: 31
tbird probs :(

i got a 94 3.8 and i have put dual exhaust on it with no cats or anything just pipes and mufflers and now my car kind of sputtters after i let of the gas when going down the road and when its real cold it shifts kind of late and i really dont think its the trans. feels like somthing it up with my gas . i put new oil pump on it and oil gauge thats by the pump and some how i still get low oil pressure WTF lol. someone said that could be do to not enough back pressure from my exhaust.. all of this.
i got 2" pipes going back into 40 flows. also put 2 new 02 sensors on the car and i also put a bigger MAF on it too, maybe somthing is up with the maf
Can anyone help me with this sputter problem i have?
FLOo is offline  
Sponsored Links
Advertisement
 
post #2 of 15 (permalink) Old 08-26-2005, 06:08 PM
Administrator
 
Litning's Avatar
 
Join Date: Nov 2003
Location: Land of Confusion
Posts: 2,976
why did you put on a bigger maf? put your old one back on. I bet that will fix your problem. You have NO need for a bigger maf. hell, I know of modified 4.6's that are still using the stock maf.
Litning is offline  
post #3 of 15 (permalink) Old 08-26-2005, 10:20 PM
The Parts Guy
 
racecougar's Avatar
 
Join Date: Jul 2002
Location: Imperial, Missouri (near St. L
Age: 36
Posts: 7,265


Put the stock MAF back on.

-Rod

Rod @ AzzKicker Cars
[email protected]
90 XR7-The Meth Addict-KB SC'd 5.0L DOHC Stroker
2004 Mustang GT-The Driver-Intake/Exhaust/3.73's
1995 F150 4x4-The Mud Toy-5.0L/4R70W/33's/Warn 8274 Winch
94 LX w/Splitport 3.8L from 2000 Mustang - SOLD
2 - 90 35th Anny Ed SC's
And a TON of parts cars!
racecougar is offline  
Sponsored Links
Advertisement
 
post #4 of 15 (permalink) Old 08-26-2005, 11:41 PM Thread Starter
 
Join Date: Jun 2005
Posts: 31
i thought it would add more HP hehe... well i got a cam reground for the motor and heads done up. thought i would need more air going through too..,. soo i put bigger MAF
FLOo is offline  
post #5 of 15 (permalink) Old 08-27-2005, 07:01 AM
Administrator
 
Litning's Avatar
 
Join Date: Nov 2003
Location: Land of Confusion
Posts: 2,976
In order to use a bigger MAF, you need a chip to let the computer know you have a bigger maf.

Last edited by Litning; 08-27-2005 at 01:44 PM.
Litning is offline  
post #6 of 15 (permalink) Old 08-27-2005, 08:19 AM
6th Gear Poster
 
cougarfan's Avatar
 
Join Date: Jun 2004
Location: tamworth nh snow country
Age: 48
Posts: 689
Send a message via AIM to cougarfan Send a message via Yahoo to cougarfan
Quote:
Originally Posted by Litning
In order to use a bigger MAF, you need a chip to let the computer know you have a bigger chip.
dont you mean bigger maf john

brakes we dont need no stinking brakes just stand on the gas
my car domain site
http://www.cardomain.com/ride/535118
myspace page
http://www.myspace.com/caffine231
when life hands you lemons ... ask for Tequila and salt and call me over!
cougarfan is offline  
post #7 of 15 (permalink) Old 08-27-2005, 09:26 AM Thread Starter
 
Join Date: Jun 2005
Posts: 31
welll im going to change out the MAF today to see if it help .. thanks for the help bros
FLOo is offline  
post #8 of 15 (permalink) Old 08-27-2005, 09:49 AM Thread Starter
 
Join Date: Jun 2005
Posts: 31
fck i dont have my old one, guess i will have to go to a junk yard to get one. but b4 i do.. would the MAF be causing this super bad gas milage, sputtering after letting off throttle, low oil pressure(after putting in new oil pump and new oil senser), and late shifting when the motor is real cold?
FLOo is offline  
post #9 of 15 (permalink) Old 08-27-2005, 10:20 AM
The Parts Guy
 
racecougar's Avatar
 
Join Date: Jul 2002
Location: Imperial, Missouri (near St. L
Age: 36
Posts: 7,265
The wrong MAF could cause all of those symptoms except for the low oil pressure.

-Rod

Rod @ AzzKicker Cars
[email protected]
90 XR7-The Meth Addict-KB SC'd 5.0L DOHC Stroker
2004 Mustang GT-The Driver-Intake/Exhaust/3.73's
1995 F150 4x4-The Mud Toy-5.0L/4R70W/33's/Warn 8274 Winch
94 LX w/Splitport 3.8L from 2000 Mustang - SOLD
2 - 90 35th Anny Ed SC's
And a TON of parts cars!
racecougar is offline  
post #10 of 15 (permalink) Old 08-27-2005, 10:31 AM Thread Starter
 
Join Date: Jun 2005
Posts: 31
maybe the oil pressure is just the gauge in my car. sometimes its normal and somtimes it goes a lil low.
FLOo is offline  
post #11 of 15 (permalink) Old 08-27-2005, 05:44 PM
Moderator
Iowa Chapter Director
Uber Luber
TCCoAAC Member
Moderator
 
Thomas's Avatar
 
Join Date: Jul 2002
Location: Ames, Iowa
Age: 35
Posts: 8,978
the oil pressure gauge is a dummy gauge. It's either reading pressure or it's not. So if it shows "a little low" then its fine.
-Thomas

1988 Notch Mustang: - 438W, direct port n2o, t56
2003 SVT Focus: - SCT X3 tuner
Thomas is offline  
post #12 of 15 (permalink) Old 08-27-2005, 07:17 PM Thread Starter
 
Join Date: Jun 2005
Posts: 31
ya it never goes all the way to low .. must be the gauge. thx for the help guys
i gotta find a MAF somehwere none of the junk yards around here got one
FLOo is offline  
post #13 of 15 (permalink) Old 08-27-2005, 07:26 PM
Administrator
 
Litning's Avatar
 
Join Date: Nov 2003
Location: Land of Confusion
Posts: 2,976
Quote:
Originally Posted by cougarfan
dont you mean bigger maf john
yup, thanks joe... was on the way out the door to my sister's college when i wrote that
Litning is offline  
post #14 of 15 (permalink) Old 08-27-2005, 08:34 PM Thread Starter
 
Join Date: Jun 2005
Posts: 31
OMG it was the MAF i found my old one in the shed and put it on and it runs just fine now hehe. thanks for the help guys !! now i can sell this piece of sht haha
FLOo is offline  
post #15 of 15 (permalink) Old 08-28-2005, 04:11 PM
6th Gear Poster
 
cougarfan's Avatar
 
Join Date: Jun 2004
Location: tamworth nh snow country
Age: 48
Posts: 689
Send a message via AIM to cougarfan Send a message via Yahoo to cougarfan
np anytime

brakes we dont need no stinking brakes just stand on the gas
my car domain site
http://www.cardomain.com/ride/535118
myspace page
http://www.myspace.com/caffine231
when life hands you lemons ... ask for Tequila and salt and call me over!
cougarfan is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the TCCoA Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome