3.8 can't find the lean... - TCCoA Forums
 
LinkBack Thread Tools
post #1 of 13 (permalink) Old 09-29-2005, 01:44 PM Thread Starter
 
Join Date: Sep 2005
Posts: 17
3.8 can't find the lean...

Just for history, just cracking 100kmiles on my 90lx, we did the head gaskets last november.. so all the gaskets up that way should be pretty new..
About may or june, this thing started giving me an occasional rough idle with a check engine light.. it grew more consistent over a few weeks, so I pulled the codes..
it gave me a O2 sensor lean code for each side (was it 47 & 97?)..
So I bought new coi, dist cap, wires, plugs, and O2 sensors..
Well I changed it all, except the drivers side O2, which even with the loaner tool for the job, I just could not break loose..
cleared the codes, got the same.. lean on both sides.. well I guess it wasn't the sensor..
But, after than the car RUNS ok, seems to actually perform as it did before.. with the exception of little power from a stop (I'm gertting the idea that's normal) it seems to run fine.. once in a while I will start it and it'll idle like crap until it warms up, but even that's few and far between..
yet now the check engine light is always on.. and it bugs the piss out of me..
since then I've tightened up what seemed to be a slightly loose egr valve from the head gasket job, replaced all the vacuum lines (except the ones entering the firewall, which I plugged off for a test), map sensor, fuel filter.. and then ran out of ideas, except maybe a couple I don't want to face..
I've soaked quite a bit of dough into unrelated things on this car lately, I want it to be 100% so it's not all in vain..

What are my leftover possibilities here? please give me something I haven't thought of..
90lxbeater is offline  
Sponsored Links
Advertisement
 
post #2 of 13 (permalink) Old 09-29-2005, 01:48 PM
PCD
Confirmed V6 Nut
 
Join Date: Aug 2002
Location: Dubuque, Iowa
Age: 63
Posts: 2,261
My 97 ocasionally runs rough at start up. I heard it is the nature of the 3.8.

The Parts Bin Special is DEAD! It is being parted out.
PCD is offline  
post #3 of 13 (permalink) Old 09-29-2005, 08:09 PM
Seasoned PostWhore
 
The Stevinator's Avatar
 
Join Date: Sep 2004
Location: Houston
Age: 35
Posts: 2,659
Send a message via AIM to The Stevinator
well think of it this way. less things you will have to repair later down the road. you may want to try changing your cats. you run ****ty gas through your car? they could be clogged causing your o2's to go off. hell, if your gonna do that, might as well just do your whole exhaust system though. hey PCD how did you do your fold down rear seat? just curious i always loved those things.
The Stevinator is offline  
Sponsored Links
Advertisement
 
post #4 of 13 (permalink) Old 09-30-2005, 06:51 AM Thread Starter
 
Join Date: Sep 2005
Posts: 17
I have little adversion to chopping out those cats.. it'd make it rumble nice
but I have a hard time believing they would be clogged this long without showing any of the traditional symptoms performance-wise (running worse ->stalling as the car heats up, unusually small exhaust output, blowing seals).. I've had cats clog before, I'm seeing none of that.. if there is ever a miss in it, it's when it's cooled..

it seems to me I'm looking at something that went bad in a short period, has only a small impact, yet on both sides, and is as toast as it's getting..
I'm looking around for a fuel pressure guage atm, although I have a hard time with the idea of a weak fuel pump going a couple thousand miles without dying completely too..

Last edited by 90lxbeater; 09-30-2005 at 07:29 AM.
90lxbeater is offline  
post #5 of 13 (permalink) Old 09-30-2005, 08:12 AM
PCD
Confirmed V6 Nut
 
Join Date: Aug 2002
Location: Dubuque, Iowa
Age: 63
Posts: 2,261
Stevinator, you have a PM coming.

The Parts Bin Special is DEAD! It is being parted out.
PCD is offline  
post #6 of 13 (permalink) Old 09-30-2005, 09:08 AM Thread Starter
 
Join Date: Sep 2005
Posts: 17
you know, I soaked a good bit of cash into this problem.. and I think I just fixed it..
and I'm not happy about it...
ya know that schrader valve on the rail? well the cap for it was gone.. I just put a new cap on it..
every day for the last 6ish months the check engine light would come on within 5 secs of starting the car.. I just drove it a couple miles with that cap back on.. it never came on..
Wheres the kickin my own azz smiley at here?
90lxbeater is offline  
post #7 of 13 (permalink) Old 09-30-2005, 10:12 AM
Seasoned PostWhore
 
The Stevinator's Avatar
 
Join Date: Sep 2004
Location: Houston
Age: 35
Posts: 2,659
Send a message via AIM to The Stevinator
oh no....haha dude that sucks! but look on the bright side. you wont have to fix that other **** down the road.
The Stevinator is offline  
post #8 of 13 (permalink) Old 09-30-2005, 10:55 AM Thread Starter
 
Join Date: Sep 2005
Posts: 17
wouldn't say all that, getting my 2nd strut rod bushing done tuesday after ~ 21/2 years since the last $400 job(had them both done)..
atleast it was only 1 this time, but ball joints to go with it..lol

I'll give it a week after I pay for that until the tranny goes..

still talking myself into doing the heater core.. getting cold here..

soon I'll have a whole new car!
90lxbeater is offline  
post #9 of 13 (permalink) Old 09-30-2005, 11:13 AM
Seasoned PostWhore
 
The Stevinator's Avatar
 
Join Date: Sep 2004
Location: Houston
Age: 35
Posts: 2,659
Send a message via AIM to The Stevinator
hahah i know! i've been through 3 trannys so far. the last one got cracked clean in half on the tail. i repeat got cracked clean in half. the U joint at the driveshaft came off at about 100 mph and whipped around and destroyed my trans. hopefully if i get this job im applying for i'll have the money to rebuild my car. my suspension is in some hardcore need of TLC. and the engine needs to be rebuilt
The Stevinator is offline  
post #10 of 13 (permalink) Old 09-30-2005, 12:17 PM
PCD
Confirmed V6 Nut
 
Join Date: Aug 2002
Location: Dubuque, Iowa
Age: 63
Posts: 2,261
90lxbeater, Ugh, I did the heater core with my brother's help in his driveway. I spent the night because it took 8 hours the first day and 4 the next to change the heater core. All the time I had to listen to, "In my 85 Buick over there, all I have to do is open the hood and lift a panel to change the heater core....", the whole time.

The Parts Bin Special is DEAD! It is being parted out.
PCD is offline  
post #11 of 13 (permalink) Old 09-30-2005, 07:51 PM Thread Starter
 
Join Date: Sep 2005
Posts: 17
meh.. now it's come back on for a while.. went back out just before I got home..
intermittent problems are worse than any
90lxbeater is offline  
post #12 of 13 (permalink) Old 10-01-2005, 12:04 AM
Resident redneck
 
redneckcougarguy's Avatar
 
Join Date: Feb 2005
Location: Olmsted Falls, OH
Age: 33
Posts: 1,921
Send a message via AIM to redneckcougarguy Send a message via MSN to redneckcougarguy
where in ohio are you at? someone somewhere might be of assistance

-Steven

Project Rust Prevention: 1990 Buick Regal, Toilet Capacity engine, new trim paint, 57K miles
redneckcougarguy is offline  
post #13 of 13 (permalink) Old 10-03-2005, 12:24 PM Thread Starter
 
Join Date: Sep 2005
Posts: 17
zanesville..
seems to be staying out for the most part now, might even be an entirely different code for all I know.. but I'm going to have to give this one a rest for the next couple weeks, to concentrate on the other things for now.. if it's still an issue I'll get back into it..
90lxbeater is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the TCCoA Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome