3.8 stumbling, rough idle after fuel rail change- - TCCoA Forums
 
LinkBack Thread Tools
post #1 of 1 (permalink) Old 12-18-2006, 05:39 PM Thread Starter
 
Join Date: Feb 2005
Posts: 73
3.8 stumbling, rough idle after fuel rail change-

Been a mess. Fuel line got damaged... swapped it not once, but twice w/ a junk yard set up. First one was damaged, so I did the second one. I took the car out, and noted that fuel was leaking from the schrader valve. Corrected that, still getting an errant idle with stumbling. I've done the upper intake swap about 7 or 8 times, so I'm faily sure I know all the connections, but list a few that, if missed, would cause this (could be that simple). Any thought on the fuel system? I swapped out the regulator with a newer one, but still a junk yard one. I'm worried about the injectors. Tips are a bit cracked on em, not the best looking units. Give me some ideas here.

Thanx

J
313speed is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the TCCoA Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome