Trans swap problems. - TCCoA Forums
 
LinkBack Thread Tools
post #1 of 8 (permalink) Old 04-20-2010, 12:14 PM Thread Starter
2nd Gear Poster
 
Join Date: Oct 2006
Location: Dayton
Posts: 97
Trans swap problems.

I have a 95 cougar that had a 99 grand marquis trans swapped in about 2 years ago. I have since fried that trans and have now swapped in a 96 t-bird trans.

I have swapped over the valve body that has been j-modded, 3500 stall torque converter and all the solenoids and parts to the upgraded connections.

The only gear that I have is 1st gear. The rpms drop in all gears but 2nd and the car only egages in first. I have been trying figure it out for the last couple of days with no success. I was hoping someone may be able to point in the right direction on what to check.

Thanks Rick.

PI head and intake swap, J modded 99 trans w/ 3500 Stall Dirty Dog converter, Mark VIII drive shaft & pumpkin with 3.73 and sct tuned. Mid mount Magnaflow di/do, kyb's and springtech springs. Tuned by Precision Autosports.

Best time 13.91 @ 97

http://i3.photobucket.com/albums/y57...arterView2.jpg
henry74 is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 04-20-2010, 04:33 PM
Seasoned PostWhore
 
dDUBb's Avatar
 
Join Date: Dec 2006
Location: Nor-Cal
Age: 38
Posts: 4,142
Garage
Was the trans working in the 96 Tbird ??
dDUBb is offline  
post #3 of 8 (permalink) Old 04-20-2010, 08:49 PM
Seasoned PostWhore
 
95xbird's Avatar
 
Join Date: Apr 2006
Location: Buffalo, NY
Age: 36
Posts: 4,407
Send a message via AIM to 95xbird Send a message via MSN to 95xbird
MLPS switch. Make sure its properly lined up. Start there

04 PI swap,SVO Supercharger 8-9 psi,Alcohol injection,39lbs Cobra injectors,XCal2-Walbro 255 LPH fuel pump,4.10 T-Lok,2003 4R70W built to withstand by RobertP,450hp JMOD,3800 circleD stall,trucool 4739 Trans Cooler,Dynotech 3.5 Driveshaft,70mm T/B,SCP Cold Air Intake,90mm LMAF,JBA headers,Magnaflow Midmount,No cats with 3inch piping,Vogtland 1.6inch drop,Cobra R's and xenon body kit.

Its slow, Really.
LS1 KILLER
1995 svo Tbird. R.I.P.
Parts FOR SALE http://forums.tccoa.com/showthread.php?t=132585
96 Pearl white bird. Awaiting transplants from the 95
95xbird is offline  
Sponsored Links
Advertisement
 
post #4 of 8 (permalink) Old 04-20-2010, 09:36 PM Thread Starter
2nd Gear Poster
 
Join Date: Oct 2006
Location: Dayton
Posts: 97
I'm a bone head, I figured it out. I somehow managed to forget to seat the mlps back into the slot on the inside of the trans. It works now, pretty sad it took me a couple of days to figure it out.

PI head and intake swap, J modded 99 trans w/ 3500 Stall Dirty Dog converter, Mark VIII drive shaft & pumpkin with 3.73 and sct tuned. Mid mount Magnaflow di/do, kyb's and springtech springs. Tuned by Precision Autosports.

Best time 13.91 @ 97

http://i3.photobucket.com/albums/y57...arterView2.jpg
henry74 is offline  
post #5 of 8 (permalink) Old 04-20-2010, 10:37 PM
PostWhore
 
94TchikinV8's Avatar
 
Join Date: Jan 2003
Location: Lebanon, OH
Age: 34
Posts: 1,222
Send a message via AIM to 94TchikinV8 Send a message via Yahoo to 94TchikinV8
Glad you got it figured out Rick. I'm going to be back in town Thursday afternoon probably. Kil-Kare?

-Rob

1994 Thunderbird LX V8

Still in pieces in the garage awaiting body work, paint, and a drivetrain...

Currently driving a 98 Mustang GT convertible:
02 Explorer engine, Comp 262ah cams, Steeda underdrives, aftermarket H-pipe with high flow cats, SLP LM1 exhaust, MGW shifter, RAM clutch
[email protected], 2.17 60ft(stock 2.73s, worn-out trac-lok)
94TchikinV8 is offline  
post #6 of 8 (permalink) Old 04-20-2010, 11:11 PM Thread Starter
2nd Gear Poster
 
Join Date: Oct 2006
Location: Dayton
Posts: 97
I am not sure yet, I still have to finish up the exhaust and a small coolant leak. I drove down to the end of the block and it seems to be okay but in park and neutral it is idling a little high 1200 rpms. Might be from all the changes and no cats yet. I am going to try to get it finished tomorrow.

PI head and intake swap, J modded 99 trans w/ 3500 Stall Dirty Dog converter, Mark VIII drive shaft & pumpkin with 3.73 and sct tuned. Mid mount Magnaflow di/do, kyb's and springtech springs. Tuned by Precision Autosports.

Best time 13.91 @ 97

http://i3.photobucket.com/albums/y57...arterView2.jpg
henry74 is offline  
post #7 of 8 (permalink) Old 04-21-2010, 07:33 PM
PostWhore
 
94TchikinV8's Avatar
 
Join Date: Jan 2003
Location: Lebanon, OH
Age: 34
Posts: 1,222
Send a message via AIM to 94TchikinV8 Send a message via Yahoo to 94TchikinV8
Quote:
Originally Posted by henry74 View Post
I am not sure yet, I still have to finish up the exhaust and a small coolant leak. I drove down to the end of the block and it seems to be okay but in park and neutral it is idling a little high 1200 rpms. Might be from all the changes and no cats yet. I am going to try to get it finished tomorrow.
Did you ever get it retuned after the trans and converter?

-Rob

1994 Thunderbird LX V8

Still in pieces in the garage awaiting body work, paint, and a drivetrain...

Currently driving a 98 Mustang GT convertible:
02 Explorer engine, Comp 262ah cams, Steeda underdrives, aftermarket H-pipe with high flow cats, SLP LM1 exhaust, MGW shifter, RAM clutch
[email protected], 2.17 60ft(stock 2.73s, worn-out trac-lok)
94TchikinV8 is offline  
post #8 of 8 (permalink) Old 04-21-2010, 11:25 PM Thread Starter
2nd Gear Poster
 
Join Date: Oct 2006
Location: Dayton
Posts: 97
Quote:
Originally Posted by 94TchikinV8 View Post
Did you ever get it retuned after the trans and converter?

-Rob
I had it tuned after we put in the converter and trans. I think it just needs to be tuned again after all of the changes this go around. I thought I would have fixed the oil leak with a new pan gasket but it turns out to be even worse...when rains it pours!

PI head and intake swap, J modded 99 trans w/ 3500 Stall Dirty Dog converter, Mark VIII drive shaft & pumpkin with 3.73 and sct tuned. Mid mount Magnaflow di/do, kyb's and springtech springs. Tuned by Precision Autosports.

Best time 13.91 @ 97

http://i3.photobucket.com/albums/y57...arterView2.jpg
henry74 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the TCCoA Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome