Possible water in 95 Auto transmission? - TCCoA Forums
 
LinkBack Thread Tools
post #1 of 8 (permalink) Old 04-30-2010, 09:56 AM Thread Starter
Newbie
 
Join Date: Aug 2008
Location: Palm Harbor
Posts: 22
$1100 for replaced AT? Help!

Hi, perhaps I do not post questions well and I apologize. I hope I do better this time. My car flares between 1-2 shifts unless I shift from 1-2, then it flares between 2-3, OD fine. We did have flooding and day before this began and significant puddles were unavoidable and though I could have drove through them more slowly I was afraid it might stall. Could water have entered vent hole and be causing this and what damage and roughly what repair prices am I looking at? I know we have several trans pro's here , please help.
Thank you.

Edit: Trans place called a want $1100 to replace trans, not rebuild. I've seen kits from dirtydog and silverfox from around $250-$400 are these what I would need to do the same?
P.S. I saw in thread that a couple fellas live in Tampa Bay area that did their own rebuilds and would sure like to hire one of them to do the job if the above is what I need.

Last edited by Laramie; 04-30-2010 at 10:21 AM. Reason: $1100 for replaced AT? Help!
Laramie is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 04-30-2010, 01:22 PM
Newbie
Moderator
 
master486's Avatar
 
Join Date: Jun 2006
Location: San Diego
Age: 32
Posts: 5,650
If you were submerged enough to get to the vent, the exhaust would have been under too and the engine would have stalled. The vent is pretty high up there. Plus you would have gotten water inside the car.

--Chris

DirtyDog Torque Converter For Sale!!
Huge Parts Sale!!

1996 Thunderbird LX
Awaiting some tender deconstruction...
master486 is offline  
post #3 of 8 (permalink) Old 04-30-2010, 03:47 PM
3rd Gear Poster
 
Join Date: Feb 2010
Location: Benton, Ky
Posts: 162
have ya checked the fluid level in ya trans? it could just be low
hershy314 is offline  
Sponsored Links
Advertisement
 
post #4 of 8 (permalink) Old 04-30-2010, 05:32 PM
5th Gear Poster
 
Join Date: Jan 2010
Location: Houston
Posts: 369
if there is water in the trans you'd see the strawberry milkshake. Early trans sucked. i kno because mine went out at 50k miles or so. careful who you choose to rebuild.. its always best to buy a newer 98+ version of the trans

Forgive me When i sound like i have A.D.D.
frst4.6 is offline  
post #5 of 8 (permalink) Old 05-01-2010, 11:18 AM Thread Starter
Newbie
 
Join Date: Aug 2008
Location: Palm Harbor
Posts: 22
hey thanks guys and no, frst, i dont think I have a strawberry milkshake by that do you mean lighter in color and thicker? I'm wondering if it is lighter in color but definitely not thicker. Level is good hershy,and No stall, or water inside- thanks for that master cause that is a real relief. Is it strange that if I row it manually the flare is between 2-3 instead of 1-2 from 'D;'?? I have all 4 gears.
Oh, maybe a lesson to me. I took it to be scanned and tested and now i something I didn't have before- a clank when I put it into D or R. %^$^&!
I know take it back but do you really think they're gonna own up to it?
Do you think Seafoam's Trans Tune or Lucas' Trans Fix will help me keep her goin' till I can afford to replace (maybe 2 months)?
Thanks again
Laramie is offline  
post #6 of 8 (permalink) Old 05-17-2010, 06:24 AM
6th Gear Poster
 
BUCK's Avatar
 
Join Date: Jul 2009
Location: SOUTH CAROLINA
Age: 65
Posts: 649
Thumbs down

Quote:
Originally Posted by Laramie View Post
Hi, perhaps I do not post questions well and I apologize. I hope I do better this time. My car flares between 1-2 shifts unless I shift from 1-2, then it flares between 2-3, OD fine.
A 95 4R70W comes STOCK with all those FLARES from Ford~!

GET OFF MY LAWN~! ... & Let's not forget guys... There's still a dead Imaginary Ex-Girlfriend out there...
BUCK is offline  
post #7 of 8 (permalink) Old 05-17-2010, 07:15 AM
Awaiting E-Mail Confirmation
 
tinman_72's Avatar
 
Join Date: Mar 2004
Location: North GA
Posts: 2,638
Quote:
Originally Posted by BUCK View Post
A 95 4R70W comes STOCK with all those FLARES from Ford~!
Hmmm. Mine didn't. I did the j-mod at 80K miles and have never had a problem with the tranny before or after.
tinman_72 is offline  
post #8 of 8 (permalink) Old 05-17-2010, 10:27 AM
Seasoned PostWhore
 
NetKeym's Avatar
 
Join Date: Aug 2009
Location: Florida
Posts: 5,862
Quote:
Originally Posted by tinman_72 View Post
Hmmm. Mine didn't. I did the j-mod at 80K miles and have never had a problem with the tranny before or after.
My '95 same story at about the same mileage. I've had one small issue that I don't worry about.
NetKeym is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the TCCoA Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome