Well, looks like my T-converter is crapping out... - TCCoA Forums
 
LinkBack Thread Tools
post #1 of 8 (permalink) Old 11-14-2010, 02:41 AM Thread Starter
Newbie
 
Join Date: Sep 2010
Location: H.G., AL
Age: 40
Posts: 14
Send a message via AIM to SilverStreak4.6
Post Well, looks like my T-converter is crapping out...

I had noticed during the test drive it shuttered a few times. I blamed it on rough roads as there were numerous pot holes, and rough spots in the area I test drove it.
Anyway, I found this site and, discovered the torque converter issues. As it was an unfrequent occurrence in my case. However, now that is no longer the case...
I can't drive it at all without that shudder. Only way to stop it now is to vary the throttle till I reach the speed limit and, can stay there.

I just recently got a whole 96 practically given to me. Though I haven't spoke with the guy in a couple of weeks. I can get it whenever. I only wanted to buy the drivers fender off of it. I paid for the fender and, he asked if I would be interested in all of it. Of course you know my answer was yes. He said I could just take the whole thing. So, I got the car for $50 what I was paying for the fender. Car is a carbon copy of mine only one year newer. Downside it had a grenaded engine he said the guy he got it from put an inspection window in the side of the block.... But, the trans was rebuilt in 07 I saw the receipt it was done at a very good local guy's shop. I don't however see a new converter on that document. Unless it was provided by the PO.

Now, I finally get to the question. Sorry for dragging it out. Should I trust the converter in the other trans. Or, go ahead and invest in a good reputable replacement? I don't want to have to drop it again due to yet another fubar'ed converter. I am trying to come in on a budget as winter is a VERY slow season for my business. With things like they have been the past month that budget is getting slimmer everyday..... Thanks for any and, all input.
SilverStreak4.6 is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 11-14-2010, 02:48 AM
Converter Guy
 
dirtyd0g's Avatar
 
Join Date: Jul 2004
Location: batavia,oh
Age: 42
Posts: 6,617
Send a message via Yahoo to dirtyd0g
Heavy duty stock converters are considerably cheaper than the labor to install them, all factory converters have crappy clutches with a limited life, seems like a no brainer to me. Personally and I'm sure there are dozens here that will agree, these cars love stall, the more the merrier.
Alan

DirtyDog Performance.Com
Proud sponsor of the SC/XR7 Shootout and Joel Bender Memorial Nats

Please do not send me messages on forums they are too hard to keep up with and I don't check in very often anymore call me at 513 898-1580 or email me alan at dirtydogperformance.com
dirtyd0g is offline  
post #3 of 8 (permalink) Old 11-14-2010, 03:09 AM Thread Starter
Newbie
 
Join Date: Sep 2010
Location: H.G., AL
Age: 40
Posts: 14
Send a message via AIM to SilverStreak4.6
The need for stall is one I didn't know. I have been looking at D.D. Performance. com. Would the heavy duty converter/HEAW3 be sufficient. Not looking to hot rod or anything just a dependable replacement is all I need. Thanks much.
SilverStreak4.6 is offline  
Sponsored Links
Advertisement
 
post #4 of 8 (permalink) Old 11-14-2010, 12:01 PM
Converter Guy
 
dirtyd0g's Avatar
 
Join Date: Jul 2004
Location: batavia,oh
Age: 42
Posts: 6,617
Send a message via Yahoo to dirtyd0g
That will be a heavy duty upgrade to stock with little to no performance increase.
Yes it will do the job.
Alan

DirtyDog Performance.Com
Proud sponsor of the SC/XR7 Shootout and Joel Bender Memorial Nats

Please do not send me messages on forums they are too hard to keep up with and I don't check in very often anymore call me at 513 898-1580 or email me alan at dirtydogperformance.com
dirtyd0g is offline  
post #5 of 8 (permalink) Old 11-21-2010, 06:58 PM
Newbie
 
Join Date: Nov 2010
Location: Utah
Posts: 5
You know, I had the same issue with my previous Thunderbird, but after I did the j-mod it didn't shudder anymore. I think this is mostly because of the new fluid/filter. Still had stock converter. But if you are going to change it out anyway I would definitely go with DD's suggestion.
Dunesgirl is offline  
post #6 of 8 (permalink) Old 11-24-2010, 11:12 PM Thread Starter
Newbie
 
Join Date: Sep 2010
Location: H.G., AL
Age: 40
Posts: 14
Send a message via AIM to SilverStreak4.6
I have to agree with you the fluid in it does kind of look rough. Looks pretty old. Would be nice to change it, and put off having to pull the trans for a bit. Money is getting tight, and the shudder is getting on my nerves... Im probably going to have to do the cheap route for now. I have the trans out of the 96. The converter looks good. But, doubt it is new. SO, I will probably be right back where I am now before long. But, with a rebuilt trans. If the receipt from the rebuild has the correct miles from the donor car the P.O. only put about 30K on it since the rebuild. Should still be ok I hope. I get hold of some extra cash I will get the new converter so the shudders don't have a chance to return.
SilverStreak4.6 is offline  
post #7 of 8 (permalink) Old 11-25-2010, 02:23 PM
PostWhore
 
CrystalPistol's Avatar
 
Join Date: Aug 2003
Location: Shenandoah Valley
Age: 65
Posts: 1,032
SilverStreak, back in May 2009 I bought my '95 with 52,xxx miles on it and it was a one owner. First trip I drove it to a town about 30 miles away for supper and on the way home, it shuddered right around 30-40 as I recall. Furher I drove it, worse it got.

I thought "Oh Crap!".

I recalled reading threads on early 4R70Ws and looked here and it looked like a case of Mercon V and a filter might, just might .... be the cure, or so I hoped. I went back to town and got an extra case of Mercon V (had a case on the shelf and some spare bottles) and Filter and a aux cooler and changed out the fluid both in the pan and the TC and I installed the cooler .... took more like 13 qts with the new cooler.

Little ball on stick stopper upper was in pan so likely was first change since car left FOMOCO.

Cured my shudder. Very next drive, shudder gone. She's at 64,xxx miles now and never shuddered again yet.

I did J-mod recently and replaced two accumulator pistons for new and the new springs (the one under the 1-2 accum piston was broken) and I reused a lot of that same fluid I pumped into a new clean 5 gal bucket (after also filtering it through a paint strainer quart by quart to make sure no bugs fell in.

I added a few quarts for what I lost when dropping the VB though as it went into a not as clean drain pan I wasn't so sure about.

A fine pair ... ... and whatever you do, Have a Safe Trip!

Last edited by CrystalPistol; 11-25-2010 at 02:30 PM.
CrystalPistol is offline  
post #8 of 8 (permalink) Old 11-25-2010, 11:13 PM Thread Starter
Newbie
 
Join Date: Sep 2010
Location: H.G., AL
Age: 40
Posts: 14
Send a message via AIM to SilverStreak4.6
I will be going tomorrow evening to do a fluid, and filter change. I hope it works out. The need for the trans in the donor has came up. I found an engine to go in it. Even if it turns out to be the converter I still think the trans in it now is ok. So, we shall see..
SilverStreak4.6 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the TCCoA Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome