Won't move till 2k rpms - TCCoA Forums
 
LinkBack Thread Tools
post #1 of 6 (permalink) Old 11-16-2010, 09:23 AM Thread Starter
6th Gear Poster
 
Gl@re's Avatar
 
Join Date: Sep 2008
Location: Rochester, NY
Posts: 683
Won't move till 2k rpms

When I'm at a stop, and i push the gas, the engine freely revs to 2k rpms, and then it's like the torque converter locks up, and the car starts moving. is my tranny on it's last legs?

14.8 @ 95
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 11-16-2010, 09:25 AM
Voice/Data Guru
 
Boston-Bull's Avatar
 
Join Date: Nov 2007
Location: Grapevine TX
Posts: 7,781
Is the trans full of fluid ?

2017 Mustang GT 5.0L 2nd gen, cold air box,tune,6 speed auto,RGR 3.31, Magnaflow Tru X-pipe ,GT350RStrips
Gray Mustang Registry # 8582


Boston-Bull is offline  
post #3 of 6 (permalink) Old 11-16-2010, 09:29 AM
Seasoned PostWhore
 
NetKeym's Avatar
 
Join Date: Aug 2009
Location: Florida
Posts: 5,862
Quote:
Originally Posted by ThunderChecken View Post
Is the trans full of fluid ?
+1 Sounds like low on fluid. Do you have any tranny leaks? Do you hear any funny noises?

~Rick

TCCoA Sig
NetKeym is offline  
Sponsored Links
Advertisement
 
post #4 of 6 (permalink) Old 11-16-2010, 09:41 AM Thread Starter
6th Gear Poster
 
Gl@re's Avatar
 
Join Date: Sep 2008
Location: Rochester, NY
Posts: 683
If anything it is over full. Could that cause it? I had a local shop change the tranny fluid last year about this time, maybe they over filled it? would it take this long to show up?

14.8 @ 95
post #5 of 6 (permalink) Old 11-16-2010, 09:56 AM
Voice/Data Guru
 
Boston-Bull's Avatar
 
Join Date: Nov 2007
Location: Grapevine TX
Posts: 7,781
Not sure if a overfill would make one slip , But I believe a overfill would blow out seals.

2017 Mustang GT 5.0L 2nd gen, cold air box,tune,6 speed auto,RGR 3.31, Magnaflow Tru X-pipe ,GT350RStrips
Gray Mustang Registry # 8582


Boston-Bull is offline  
post #6 of 6 (permalink) Old 11-16-2010, 10:48 AM
Seasoned PostWhore

Super Moderator
 
Join Date: May 2003
Location: Tinton Falls, NJ
Age: 37
Posts: 7,462
Garage
Send a message via AIM to MadMikeyL
Overfill would not cause that directly, but depending how overfilled it is, it could put extra load on the pump, and if that starts going it could cause what you are experiencing.

-91 Cougar LS, coming soon, complete overhaul with a 427" Windsor.
-90 XR7 5-speed black on black w/sunroof, MP2, coated rotors, double intercooler, 15%OD, ported heads, comp stage 1 cam, 85mm TB, 90MM LMAF, 80# injectors, and ported big valve heads
-98 Mark VIII LSC, Procharger P600b, TR3650 swap and 3.73s.
-90 SC Automatic rustbucket winter beater
-97 Tbird Sport 4.6 Nice weather daily driver
-"Your buddy Mike is INSANE!" -ClintD's dad
MadMikeyL is online now  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the TCCoA Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome