1-2 Upper spring missing... - TCCoA Forums
 
LinkBack Thread Tools
post #1 of 5 (permalink) Old 04-15-2011, 09:32 PM Thread Starter
2nd Gear Poster
 
Cornell's Avatar
 
Join Date: Jun 2009
Location: New Jersey
Posts: 89
Question 1-2 Upper spring missing...

Yep, finally got time to get under the car to do the Jmod and when I got to the accumulator part for the 1-2 I noticed.. to my jaw dropping demise that the upper 1-2 spring on my tranny is missing!?

I checked and re checked all around me and in the trans and all over the place! NOTHING! I thought I lost my mind so I even had my wife take a look and nothing!

Anyone ever run into something like that before?

It was shocking to me because the car had a Jasper rebuilt transmission put on by the previous owner.. I am shocked that the transmission never went out on me since it has over 50k since being rebuilt!

And to add insult to injury my torque converter bolt somehow the thread is messed up as if someone forced it in before me so now it wont go back in properly and I am afraid to force it. Can you get these new or am I out of luck here?
Cornell is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 04-15-2011, 10:34 PM
Converter Guy
 
dirtyd0g's Avatar
 
Join Date: Jul 2004
Location: batavia,oh
Age: 42
Posts: 6,617
Send a message via Yahoo to dirtyd0g
Many applications did not use an upper spring.
Alan

DirtyDog Performance.Com
Proud sponsor of the SC/XR7 Shootout and Joel Bender Memorial Nats

Please do not send me messages on forums they are too hard to keep up with and I don't check in very often anymore call me at 513 898-1580 or email me alan at dirtydogperformance.com
dirtyd0g is offline  
post #3 of 5 (permalink) Old 04-16-2011, 12:09 PM Thread Starter
2nd Gear Poster
 
Cornell's Avatar
 
Join Date: Jun 2009
Location: New Jersey
Posts: 89
oh wow and here I thought it was a vital spring.
But even if the application is dead stock? would that explain lengthy 1-2 shifts?
Cornell is offline  
Sponsored Links
Advertisement
 
post #4 of 5 (permalink) Old 04-16-2011, 02:05 PM
Seasoned PostWhore
 
NetKeym's Avatar
 
Join Date: Aug 2009
Location: Florida
Posts: 5,862
Quote:
Originally Posted by Cornell View Post
oh wow and here I thought it was a vital spring.
But even if the application is dead stock? would that explain lengthy 1-2 shifts?
My 95 transmission stock HAD an upper spring and still had lengthy, sluggish 1-2 shifts. Since the j-mod, it shifts better than a brand new tranny - firm, nimble, even tire chirping at times! It's a beautiful thing, it really is!

~Rick

TCCoA Sig
NetKeym is offline  
post #5 of 5 (permalink) Old 05-31-2011, 12:31 AM
PostWhore
 
CrystalPistol's Avatar
 
Join Date: Aug 2003
Location: Shenandoah Valley
Age: 65
Posts: 1,032
My '95 LX 4.6 did NOT have an upper spring over the 1-2 accumulator ...
... but it had a 3 piece lower spring (lol ... 3 piece .... get it?).

It had started shifting hard on every shift.

A fine pair ... ... and whatever you do, Have a Safe Trip!
CrystalPistol is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the TCCoA Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome