Possible trans pump issues...need ideas - TCCoA Forums
 
LinkBack Thread Tools
post #1 of 1 (permalink) Old 06-12-2016, 12:50 PM Thread Starter
Amateur Expert
 
Embalmer's Avatar
 
Join Date: Jul 2002
Location: Amboy, Illinois
Age: 47
Posts: 1,662
Send a message via AIM to Embalmer
Possible trans pump issues...need ideas

My 97 T-Bird 4.6 has been slipping, hard engaging of 1-2 when you let off the accelerator. So I disconnected the trans cooler line to pump the fluid out so I could drop the pan and the fluid is sputtering out, maybe 3-4 quarts before it almost stops completely.

Ideas?

2007 Ford Mustang GT Premium - SOLD March 2014.
2013 Ford Taurus SHO (TUXESHO) Tuxedo Black Bone stock for now.
Embalmer is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the TCCoA Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome