Shift/ low power issue? - TCCoA Forums
 
LinkBack Thread Tools
post #1 of 5 (permalink) Old 04-02-2017, 08:03 PM Thread Starter
Newbie
 
RyanDudz's Avatar
 
Join Date: Mar 2017
Location: Buffalo NY
Posts: 16
Garage
Send a message via AIM to RyanDudz Send a message via MSN to RyanDudz
Shift/ low power issue?

Car seems to be having a hard time getting out of first gear and is really sluggish until it gets into second. Not very responsive off the line. The power band in second gear is huge. Is this just how this car should drive? Bone stock 4.6 lx. Possible issues? Transmission?

Ryan
RyanDudz is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 04-02-2017, 08:31 PM
4th Gear Poster
 
Join Date: Mar 2011
Location: Alexandria, Virginia
Posts: 215
Have you put new MERCON V trans fluid in it since you got it?
Jim3inVirginia is offline  
post #3 of 5 (permalink) Old 04-02-2017, 08:35 PM Thread Starter
Newbie
 
RyanDudz's Avatar
 
Join Date: Mar 2017
Location: Buffalo NY
Posts: 16
Garage
Send a message via AIM to RyanDudz Send a message via MSN to RyanDudz
Nope, I've heard mixed things on changing transmission fluid

Ryan
RyanDudz is offline  
Sponsored Links
Advertisement
 
post #4 of 5 (permalink) Old 04-02-2017, 08:51 PM
4th Gear Poster
 
Join Date: Mar 2011
Location: Alexandria, Virginia
Posts: 215
Ryan - I've heard mixed reviews, mostly bad, on transmission fluid flushes. But dropping the pan, replacing the filter, and putting new fluid in it is good. Highly recommend putting new transmission fluid (MERCON V) and filter on the top of your to-do list for your LX. Do a quick search on this site, recent transmission fluid and the right transmission fluid is instrumental to the life and performance of your transmission. - Jim
Jim3inVirginia is offline  
post #5 of 5 (permalink) Old 04-02-2017, 09:02 PM
PostWhore
 
Woodman's Avatar
 
Join Date: Jan 2010
Location: Duluth, MN
Age: 45
Posts: 1,896
Garage
Quote:
Originally Posted by RyanDudz View Post
Nope, I've heard mixed things on changing transmission fluid
Do it. Full drain and refill with real Mercon V. Nothing fake, nothing "compatible".

Your transmission fluid is old and worn out.

97 Thunderbird LX (The GT Bird)
2003 Explorer WAP block with Modular Head Shop "street ported" heads and Stage 2 PI NA cams, 75mm Accufab throttle body, C&L upper intake plenum, Kooks 1.75" primary/3" collector headers, 2.5" full exhaust with mid mount Magnaflow dual in/out muffler, 24lb/hr injectors, 80mm MAF, Tuning from Don @ www.lasotaracing.com, CAI that feeds from fenderwell. Jmod, 3.73:1 TL in Mark VIII carrier, Mark VIII aluminum LCAs, 93 Mark VIII driveshaft, PBR brakes (soon to be Cobras), 18x9 wheels with 35mm offset, 255/40/ZR18 Tires, Front and Rear strut/shock bracing, GR-2 shocks, Eibach 1.5" springs, 1989 SC front and rear sway bars.
Woodman is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the TCCoA Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome